summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/ppx_bin_prot')
-rw-r--r--dev-ml/ppx_bin_prot/ppx_bin_prot-113.24.00.ebuild19
1 files changed, 18 insertions, 1 deletions
diff --git a/dev-ml/ppx_bin_prot/ppx_bin_prot-113.24.00.ebuild b/dev-ml/ppx_bin_prot/ppx_bin_prot-113.24.00.ebuild
index b807702aa32a..50cf6692c41d 100644
--- a/dev-ml/ppx_bin_prot/ppx_bin_prot-113.24.00.ebuild
+++ b/dev-ml/ppx_bin_prot/ppx_bin_prot-113.24.00.ebuild
@@ -23,7 +23,24 @@ DEPEND="dev-ml/ppx_tools:=
"
RDEPEND="${DEPEND}"
+DEPEND="${DEPEND} dev-ml/opam"
S="${WORKDIR}/${MY_P}"
-DOCS=( CHANGES.md )
+src_configure() {
+ emake setup.exe
+ OASIS_SETUP_COMMAND="./setup.exe" oasis_src_configure
+}
+
+src_compile() {
+ emake
+}
+
+src_install() {
+ opam-installer -i \
+ --prefix="${ED}/usr" \
+ --libdir="${D}/$(ocamlc -where)" \
+ --docdir="${ED}/usr/share/doc/${PF}" \
+ ${PN}.install || die
+ dodoc CHANGES.md
+}