summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/ppx_compare/ppx_compare-0.16.0.ebuild')
-rw-r--r--dev-ml/ppx_compare/ppx_compare-0.16.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-ml/ppx_compare/ppx_compare-0.16.0.ebuild b/dev-ml/ppx_compare/ppx_compare-0.16.0.ebuild
new file mode 100644
index 000000000000..fcdd04ba6b95
--- /dev/null
+++ b/dev-ml/ppx_compare/ppx_compare-0.16.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="Generation of comparison functions from types"
+HOMEPAGE="https://github.com/janestreet/ppx_compare"
+SRC_URI="https://github.com/janestreet/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="+ocamlopt"
+
+DEPEND="
+ >=dev-lang/ocaml-4.14
+ dev-ml/base:${SLOT}
+ dev-ml/findlib:=
+ >=dev-ml/ppxlib-0.28.0:=
+"
+
+RDEPEND="${DEPEND}"
+
+# Error: No rule found for test/comparelib_test__Check_optims.o
+RESTRICT=test