summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/ppx_core/ppx_core-0.9.0-r1.ebuild')
-rw-r--r--dev-ml/ppx_core/ppx_core-0.9.0-r1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-ml/ppx_core/ppx_core-0.9.0-r1.ebuild b/dev-ml/ppx_core/ppx_core-0.9.0-r1.ebuild
new file mode 100644
index 000000000000..be04409bc0fa
--- /dev/null
+++ b/dev-ml/ppx_core/ppx_core-0.9.0-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Standard library for ppx rewriters"
+HOMEPAGE="https://github.com/janestreet/ppx_core"
+SRC_URI="https://github.com/janestreet/ppx_core/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="
+ dev-lang/ocaml:=
+ dev-ml/base:=
+ dev-ml/ocaml-compiler-libs:=
+ dev-ml/ppx_ast:=
+ dev-ml/ppx_traverse_builtins:=
+ dev-ml/stdio:=
+ dev-ml/ocaml-migrate-parsetree:=
+"
+RDEPEND="${DEPEND}"
+DEPEND="${DEPEND} dev-ml/opam dev-ml/jbuilder"
+
+src_install() {
+ opam-installer -i \
+ --prefix="${ED}/usr" \
+ --libdir="${D}/$(ocamlc -where)" \
+ --docdir="${ED}/usr/share/doc/${PF}" \
+ ${PN}.install || die
+}