summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/ppx_custom_printf/ppx_custom_printf-0.16.0.ebuild')
-rw-r--r--dev-ml/ppx_custom_printf/ppx_custom_printf-0.16.0.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-ml/ppx_custom_printf/ppx_custom_printf-0.16.0.ebuild b/dev-ml/ppx_custom_printf/ppx_custom_printf-0.16.0.ebuild
new file mode 100644
index 000000000000..5b8ba919077e
--- /dev/null
+++ b/dev-ml/ppx_custom_printf/ppx_custom_printf-0.16.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="Printf-style format-strings for user-defined string conversion"
+HOMEPAGE="https://github.com/janestreet/ppx_custom_printf"
+SRC_URI="https://github.com/janestreet/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="+ocamlopt"
+
+DEPEND="
+ >=dev-lang/ocaml-4.14
+ dev-ml/ppx_sexp_conv:${SLOT}
+ >=dev-ml/ppxlib-0.28.0:=
+"
+RDEPEND="${DEPEND}"