summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/ppx_optional/ppx_optional-0.14.0.ebuild')
-rw-r--r--dev-ml/ppx_optional/ppx_optional-0.14.0.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-ml/ppx_optional/ppx_optional-0.14.0.ebuild b/dev-ml/ppx_optional/ppx_optional-0.14.0.ebuild
new file mode 100644
index 000000000000..49577612a831
--- /dev/null
+++ b/dev-ml/ppx_optional/ppx_optional-0.14.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit dune
+
+DESCRIPTION="Pattern matching on flat options"
+HOMEPAGE="https://github.com/janestreet/ppx_optional"
+SRC_URI="https://github.com/janestreet/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="+ocamlopt"
+
+DEPEND="
+ dev-ml/base:=
+ dev-ml/ppxlib:=
+ dev-ml/ocaml-migrate-parsetree:=
+ dev-ml/result:=
+"
+RDEPEND="${DEPEND}"