summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/ppx_tools/ppx_tools-4.03.0.ebuild')
-rw-r--r--dev-ml/ppx_tools/ppx_tools-4.03.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-ml/ppx_tools/ppx_tools-4.03.0.ebuild b/dev-ml/ppx_tools/ppx_tools-4.03.0.ebuild
new file mode 100644
index 000000000000..56565e700985
--- /dev/null
+++ b/dev-ml/ppx_tools/ppx_tools-4.03.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit findlib
+
+DESCRIPTION="Tools for authors of ppx rewriters"
+HOMEPAGE="https://github.com/alainfrisch/ppx_tools"
+SRC_URI="https://github.com/alainfrisch/ppx_tools/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND=">=dev-lang/ocaml-4.03.0_beta:="
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ emake -j1
+}
+
+src_install() {
+ findlib_src_install
+ dodoc README.md
+}