summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/stdio/stdio-0.9.0-r1.ebuild')
-rw-r--r--dev-ml/stdio/stdio-0.9.0-r1.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-ml/stdio/stdio-0.9.0-r1.ebuild b/dev-ml/stdio/stdio-0.9.0-r1.ebuild
new file mode 100644
index 000000000000..7e8b8d66be2b
--- /dev/null
+++ b/dev-ml/stdio/stdio-0.9.0-r1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit opam
+
+DESCRIPTION="Standard IO Library for OCaml"
+HOMEPAGE="https://github.com/janestreet/stdio"
+SRC_URI="https://github.com/janestreet/stdio/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~ppc"
+IUSE=""
+
+RDEPEND="dev-ml/base:= dev-ml/sexplib:="
+DEPEND="${RDEPEND} dev-ml/jbuilder"
+
+src_test() {
+ jbuilder runtest || die
+}