summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/textutils_kernel/textutils_kernel-0.16.0.ebuild')
-rw-r--r--dev-ml/textutils_kernel/textutils_kernel-0.16.0.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-ml/textutils_kernel/textutils_kernel-0.16.0.ebuild b/dev-ml/textutils_kernel/textutils_kernel-0.16.0.ebuild
new file mode 100644
index 000000000000..37289a18f25c
--- /dev/null
+++ b/dev-ml/textutils_kernel/textutils_kernel-0.16.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="Text output utilities"
+HOMEPAGE="https://github.com/janestreet/textutils_kernel"
+SRC_URI="https://github.com/janestreet/${PN}/archive/refs/tags/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="+ocamlopt"
+
+DEPEND="
+ >=dev-lang/ocaml-4.14
+ dev-ml/core:${SLOT}
+ dev-ml/ppx_jane:${SLOT}
+ >=dev-ml/uutf-1.0.2:=
+"
+RDEPEND="${DEPEND}"
+BDEPEND=""