summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/typerep/typerep-112.35.00.ebuild')
-rw-r--r--dev-ml/typerep/typerep-112.35.00.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-ml/typerep/typerep-112.35.00.ebuild b/dev-ml/typerep/typerep-112.35.00.ebuild
new file mode 100644
index 000000000000..c5f353aa6fc4
--- /dev/null
+++ b/dev-ml/typerep/typerep-112.35.00.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit oasis
+
+MY_P=${PN/-/_}-${PV}
+DESCRIPTION="Library for creating runtime representation of OCaml types"
+HOMEPAGE="http://www.janestreet.com/ocaml"
+SRC_URI="http://ocaml.janestreet.com/ocaml-core/${PV%.*}/files/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1-with-linking-exception"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="
+ >=dev-ml/type-conv-111.13:=
+ dev-ml/camlp4:="
+
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"