summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/utop/utop-2.9.0.ebuild')
-rw-r--r--dev-ml/utop/utop-2.9.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-ml/utop/utop-2.9.0.ebuild b/dev-ml/utop/utop-2.9.0.ebuild
new file mode 100644
index 000000000000..d5b493a8c2cf
--- /dev/null
+++ b/dev-ml/utop/utop-2.9.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit dune
+
+DESCRIPTION="Universal toplevel for OCaml"
+HOMEPAGE="https://github.com/ocaml-community/utop"
+SRC_URI="https://github.com/ocaml-community/utop/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+ocamlopt"
+
+RDEPEND="
+ dev-ml/camomile:=
+ dev-ml/lambda-term:=
+ dev-ml/lwt:=
+ dev-ml/react:=
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-ml/cppo
+ dev-ml/findlib
+"