summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/uuidm/uuidm-0.9.7.ebuild')
-rw-r--r--dev-ml/uuidm/uuidm-0.9.7.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-ml/uuidm/uuidm-0.9.7.ebuild b/dev-ml/uuidm/uuidm-0.9.7.ebuild
new file mode 100644
index 000000000000..867adf732171
--- /dev/null
+++ b/dev-ml/uuidm/uuidm-0.9.7.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit opam
+
+DESCRIPTION="Universally unique identifiers (UUIDs) for OCaml"
+HOMEPAGE="https://github.com/dbuenzli/uuidm"
+SRC_URI="https://github.com/dbuenzli/uuidm/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="+ocamlopt"
+
+BDEPEND="
+ dev-ml/findlib[ocamlopt=]
+ dev-ml/ocamlbuild[ocamlopt=]
+ dev-ml/topkg
+"
+
+src_compile() {
+ ocaml pkg/pkg.ml build || die
+}