summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/yojson/yojson-1.3.3.ebuild')
-rw-r--r--dev-ml/yojson/yojson-1.3.3.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-ml/yojson/yojson-1.3.3.ebuild b/dev-ml/yojson/yojson-1.3.3.ebuild
new file mode 100644
index 000000000000..cec3303a4626
--- /dev/null
+++ b/dev-ml/yojson/yojson-1.3.3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit findlib
+
+DESCRIPTION="JSON parsing and pretty-printing library for OCaml"
+HOMEPAGE="http://mjambon.com/yojson.html"
+SRC_URI="https://github.com/mjambon/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0/${PV}"
+LICENSE="BSD"
+KEYWORDS="~amd64"
+IUSE="examples"
+
+RDEPEND=">=dev-lang/ocaml-3.11:=[ocamlopt]
+ dev-ml/easy-format:=[ocamlopt]
+ dev-ml/biniou:=[ocamlopt]
+"
+DEPEND="${RDEPEND}
+ dev-ml/cppo
+"
+
+src_compile() {
+ emake -j1
+}
+
+src_install() {
+ dodir /usr/bin
+ findlib_src_install BINDIR="${ED}"/usr/bin
+ dodoc README.md Changes
+ if use examples ; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}