summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/Authen-PAM')
-rw-r--r--dev-perl/Authen-PAM/Authen-PAM-0.160.0-r2.ebuild43
1 files changed, 0 insertions, 43 deletions
diff --git a/dev-perl/Authen-PAM/Authen-PAM-0.160.0-r2.ebuild b/dev-perl/Authen-PAM/Authen-PAM-0.160.0-r2.ebuild
deleted file mode 100644
index fbf9fb86829e..000000000000
--- a/dev-perl/Authen-PAM/Authen-PAM-0.160.0-r2.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-DIST_AUTHOR=NIKIP
-DIST_VERSION=0.16
-DIST_EXAMPLES=("test.pl")
-inherit perl-module
-
-DESCRIPTION="Interface to PAM library"
-
-SLOT="0"
-KEYWORDS="~alpha amd64 arm hppa ~ia64 ppc ppc64 s390 sparc x86"
-IUSE="examples"
-
-RDEPEND="sys-libs/pam"
-DEPEND="${RDEPEND}"
-PATCHES=("${FILESDIR}/no-dot-inc.patch")
-export OPTIMIZE="$CFLAGS"
-
-src_test() {
- local MODULES=(
- "Authen::PAM ${DIST_VERSION}"
- )
- local failed=()
- for dep in "${MODULES[@]}"; do
- ebegin "Compile testing ${dep}"
- perl -Mblib="${S}" -M"${dep} ()" -e1
- eend $? || failed+=( "$dep" )
- done
- if [[ ${failed[@]} ]]; then
- echo
- eerror "One or more modules failed compile:";
- for dep in "${failed[@]}"; do
- eerror " ${dep}"
- done
- die "Failing due to module compilation errors";
- fi
- ewarn "To comprehensively test this module, interactive testing is necessary"
- ewarn "For details, see:"
- ewarn "https://wiki.gentoo.org/wiki/Project:Perl/maint-notes/dev-perl/Authen-PAM"
-}