summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/Cache-FastMmap/Cache-FastMmap-1.560.0.ebuild')
-rw-r--r--dev-perl/Cache-FastMmap/Cache-FastMmap-1.560.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-perl/Cache-FastMmap/Cache-FastMmap-1.560.0.ebuild b/dev-perl/Cache-FastMmap/Cache-FastMmap-1.560.0.ebuild
new file mode 100644
index 000000000000..167d2480a218
--- /dev/null
+++ b/dev-perl/Cache-FastMmap/Cache-FastMmap-1.560.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=ROBM
+DIST_VERSION=1.56
+inherit perl-module
+
+DESCRIPTION="Uses an mmaped file to act as a shared memory interprocess cache"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ virtual/perl-Storable
+"
+BDEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? ( dev-perl/Test-Deep )
+"
+
+src_compile() {
+ mymake=(
+ "OPTIMIZE=${CFLAGS}"
+ )
+ perl-module_src_compile
+}