summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/Coro')
-rw-r--r--dev-perl/Coro/Coro-6.410.0.ebuild29
-rw-r--r--dev-perl/Coro/Coro-6.420.0.ebuild29
-rw-r--r--dev-perl/Coro/Coro-6.470.0.ebuild30
-rw-r--r--dev-perl/Coro/Manifest3
-rw-r--r--dev-perl/Coro/metadata.xml33
5 files changed, 124 insertions, 0 deletions
diff --git a/dev-perl/Coro/Coro-6.410.0.ebuild b/dev-perl/Coro/Coro-6.410.0.ebuild
new file mode 100644
index 000000000000..780c10528209
--- /dev/null
+++ b/dev-perl/Coro/Coro-6.410.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=MLEHMANN
+MODULE_VERSION=6.41
+inherit perl-module
+
+DESCRIPTION="The only real threads in perl"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ >=dev-perl/AnyEvent-5
+ >=dev-perl/Guard-0.500.0
+ virtual/perl-Scalar-List-Utils
+ >=virtual/perl-Storable-2.150.0
+ dev-perl/common-sense
+ <dev-lang/perl-5.22.0
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+"
+
+SRC_TEST="do"
diff --git a/dev-perl/Coro/Coro-6.420.0.ebuild b/dev-perl/Coro/Coro-6.420.0.ebuild
new file mode 100644
index 000000000000..7fba70788e6f
--- /dev/null
+++ b/dev-perl/Coro/Coro-6.420.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=MLEHMANN
+MODULE_VERSION=6.42
+inherit perl-module
+
+DESCRIPTION="The only real threads in perl"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ >=dev-perl/AnyEvent-5
+ >=dev-perl/Guard-0.500.0
+ virtual/perl-Scalar-List-Utils
+ >=virtual/perl-Storable-2.150.0
+ dev-perl/common-sense
+ <dev-lang/perl-5.22.0
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+"
+
+SRC_TEST="do"
diff --git a/dev-perl/Coro/Coro-6.470.0.ebuild b/dev-perl/Coro/Coro-6.470.0.ebuild
new file mode 100644
index 000000000000..7f1904459907
--- /dev/null
+++ b/dev-perl/Coro/Coro-6.470.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=MLEHMANN
+MODULE_VERSION=6.47
+inherit perl-module
+
+DESCRIPTION="The only real threads in perl"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ >=dev-perl/AnyEvent-5
+ >=dev-perl/Guard-0.500.0
+ virtual/perl-Scalar-List-Utils
+ >=virtual/perl-Storable-2.150.0
+ dev-perl/common-sense
+ <dev-lang/perl-5.22.0
+"
+DEPEND="${RDEPEND}
+ dev-perl/Canary-Stability
+ >=virtual/perl-ExtUtils-MakeMaker-6.520.0
+"
+
+SRC_TEST="do parallel"
diff --git a/dev-perl/Coro/Manifest b/dev-perl/Coro/Manifest
new file mode 100644
index 000000000000..d8f8ca3b68dc
--- /dev/null
+++ b/dev-perl/Coro/Manifest
@@ -0,0 +1,3 @@
+DIST Coro-6.41.tar.gz 189177 SHA256 aaffe8d389c11f36c2bb14fb3c1a5525873d86dc6b66a41e42dc50ef49552fe4 SHA512 0f628854506080681a42d455c9e5a279e6129a590345f3d70e9051c281d7457dfe711466ff2716740b319d3b925a6b55a02b24cd765292ca4f53a07cf61aace7 WHIRLPOOL 3663f189b4d162a8b1d29845111f6d420ab92f52aa028ca737d7cb718a01bd278cf3421d1d725a61a9a7cf447728cf26c6bc65698e4f30989aa3a5bc63648fd7
+DIST Coro-6.42.tar.gz 189506 SHA256 5a803c6d8a2585c96a15438c53ae3d66b078cb966c20b7db12b4278b0fd06298 SHA512 a3ca165166320bddb6d66f4dd6015a6161b830aded9bb63c8ee989fe1129601cbd9d0b94fcecc6dd0402f3609b38ed62ed7f6267e8864148e4979028f7efc9d4 WHIRLPOOL c12b18c5e42b1b123eb9d010fd80327e7534312c60adb1fd61d212ddab881fb4f5dc09b7f140c4429ccf25ff3e9c0c026d29e655d5f11236c58979b16d59d329
+DIST Coro-6.47.tar.gz 191649 SHA256 c341cd0968d61948eefcb83c4fafaf3c5b81e12676c4198e3bae2dbc1ae0c00f SHA512 2ec5bd0632f5c658b6cdfc9fca100891d213ee2c182584c5724d9e0e5f6f28441d40b25cacb50fd0ae344e744f096cbfcb40fbea02f2d6e21129d39d37fa9c94 WHIRLPOOL 54fca2de51012cb7c82ff9034279bd7fa92abac025219b1b992ee2ca195b798711af07dfd66a1bac1d51cf76afc83f2c010d44e7feadd29b931e995940fb980f
diff --git a/dev-perl/Coro/metadata.xml b/dev-perl/Coro/metadata.xml
new file mode 100644
index 000000000000..60718ce96e48
--- /dev/null
+++ b/dev-perl/Coro/metadata.xml
@@ -0,0 +1,33 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>perl</herd>
+ <upstream>
+ <remote-id type="cpan">Coro</remote-id>
+ <remote-id type="cpan-module">Coro</remote-id>
+ <remote-id type="cpan-module">Coro::AIO</remote-id>
+ <remote-id type="cpan-module">Coro::AnyEvent</remote-id>
+ <remote-id type="cpan-module">Coro::BDB</remote-id>
+ <remote-id type="cpan-module">Coro::Channel</remote-id>
+ <remote-id type="cpan-module">Coro::Debug</remote-id>
+ <remote-id type="cpan-module">Coro::EV</remote-id>
+ <remote-id type="cpan-module">Coro::Event</remote-id>
+ <remote-id type="cpan-module">Coro::Handle</remote-id>
+ <remote-id type="cpan-module">Coro::Handle::FH</remote-id>
+ <remote-id type="cpan-module">Coro::LWP</remote-id>
+ <remote-id type="cpan-module">Coro::LWP::Socket</remote-id>
+ <remote-id type="cpan-module">Coro::MakeMaker</remote-id>
+ <remote-id type="cpan-module">Coro::RWLock</remote-id>
+ <remote-id type="cpan-module">Coro::Select</remote-id>
+ <remote-id type="cpan-module">Coro::Semaphore</remote-id>
+ <remote-id type="cpan-module">Coro::SemaphoreSet</remote-id>
+ <remote-id type="cpan-module">Coro::Signal</remote-id>
+ <remote-id type="cpan-module">Coro::Socket</remote-id>
+ <remote-id type="cpan-module">Coro::Specific</remote-id>
+ <remote-id type="cpan-module">Coro::State</remote-id>
+ <remote-id type="cpan-module">Coro::Storable</remote-id>
+ <remote-id type="cpan-module">Coro::Timer</remote-id>
+ <remote-id type="cpan-module">Coro::Timer::Timeout</remote-id>
+ <remote-id type="cpan-module">Coro::Util</remote-id>
+ </upstream>
+</pkgmetadata>