summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/Crypt-Blowfish')
-rw-r--r--dev-perl/Crypt-Blowfish/Crypt-Blowfish-2.140.0-r1.ebuild19
-rw-r--r--dev-perl/Crypt-Blowfish/Crypt-Blowfish-2.140.0-r2.ebuild29
-rw-r--r--dev-perl/Crypt-Blowfish/metadata.xml2
3 files changed, 30 insertions, 20 deletions
diff --git a/dev-perl/Crypt-Blowfish/Crypt-Blowfish-2.140.0-r1.ebuild b/dev-perl/Crypt-Blowfish/Crypt-Blowfish-2.140.0-r1.ebuild
deleted file mode 100644
index 8355658f5124..000000000000
--- a/dev-perl/Crypt-Blowfish/Crypt-Blowfish-2.140.0-r1.ebuild
+++ /dev/null
@@ -1,19 +0,0 @@
-# Copyright 1999-2018 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-MODULE_AUTHOR=DPARIS
-MODULE_VERSION=2.14
-inherit perl-module
-
-DESCRIPTION="Crypt::Blowfish module for perl"
-
-LICENSE="|| ( Artistic GPL-2 )"
-SLOT="0"
-KEYWORDS="~alpha amd64 ~arm ~arm64 hppa ia64 ~mips ppc ppc64 sparc x86 ~ppc-aix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE=""
-
-SRC_TEST="do"
-
-export OPTIMIZE="${CFLAGS}"
diff --git a/dev-perl/Crypt-Blowfish/Crypt-Blowfish-2.140.0-r2.ebuild b/dev-perl/Crypt-Blowfish/Crypt-Blowfish-2.140.0-r2.ebuild
new file mode 100644
index 000000000000..3ddc88b51e4b
--- /dev/null
+++ b/dev-perl/Crypt-Blowfish/Crypt-Blowfish-2.140.0-r2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=DPARIS
+DIST_VERSION=2.14
+inherit perl-module
+
+DESCRIPTION="Perl Blowfish encryption module"
+
+LICENSE="Crypt-IDEA"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~mips ppc ppc64 ~riscv sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ dev-perl/Crypt-CBC
+ )
+"
+src_compile() {
+ mymake=(
+ "OPTIMIZE=${CFLAGS}"
+ )
+ perl-module_src_compile
+}
diff --git a/dev-perl/Crypt-Blowfish/metadata.xml b/dev-perl/Crypt-Blowfish/metadata.xml
index b66d74b14ea9..2d06907b618a 100644
--- a/dev-perl/Crypt-Blowfish/metadata.xml
+++ b/dev-perl/Crypt-Blowfish/metadata.xml
@@ -1,5 +1,5 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="project">
<email>perl@gentoo.org</email>