summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/Danga-Socket/Danga-Socket-1.620.0.ebuild')
-rw-r--r--dev-perl/Danga-Socket/Danga-Socket-1.620.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-perl/Danga-Socket/Danga-Socket-1.620.0.ebuild b/dev-perl/Danga-Socket/Danga-Socket-1.620.0.ebuild
new file mode 100644
index 000000000000..4a775955f35a
--- /dev/null
+++ b/dev-perl/Danga-Socket/Danga-Socket-1.620.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=NML
+DIST_VERSION=1.62
+inherit perl-module
+
+DESCRIPTION="A non-blocking socket object; uses epoll()"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ virtual/perl-IO
+ virtual/perl-Socket
+ dev-perl/Sys-Syscall
+ virtual/perl-Time-HiRes
+"
+BDEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ virtual/perl-Test-Simple
+ )
+"