summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/Email-MIME-Attachment-Stripper/Email-MIME-Attachment-Stripper-1.317.0-r1.ebuild')
-rw-r--r--dev-perl/Email-MIME-Attachment-Stripper/Email-MIME-Attachment-Stripper-1.317.0-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-perl/Email-MIME-Attachment-Stripper/Email-MIME-Attachment-Stripper-1.317.0-r1.ebuild b/dev-perl/Email-MIME-Attachment-Stripper/Email-MIME-Attachment-Stripper-1.317.0-r1.ebuild
new file mode 100644
index 000000000000..13f623cb2355
--- /dev/null
+++ b/dev-perl/Email-MIME-Attachment-Stripper/Email-MIME-Attachment-Stripper-1.317.0-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=RJBS
+MODULE_VERSION=1.317
+inherit perl-module
+
+DESCRIPTION="Strip the attachments from a mail"
+
+LICENSE="|| ( GPL-2 GPL-3 )" # GPL-2+
+# under the same terms as Tony's original module
+# Mail::Message::Attachment::Stripper
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 x86"
+IUSE="test"
+
+RDEPEND=">=dev-perl/Email-MIME-1.900
+ >=dev-perl/Email-MIME-ContentType-1.012"
+DEPEND="${RDEPEND}
+ test? (
+ dev-perl/Test-Pod
+ dev-perl/Test-Pod-Coverage
+ dev-perl/Capture-Tiny
+ )"
+
+SRC_TEST="do"