summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/Eval-Closure/Eval-Closure-0.130.0.ebuild')
-rw-r--r--dev-perl/Eval-Closure/Eval-Closure-0.130.0.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-perl/Eval-Closure/Eval-Closure-0.130.0.ebuild b/dev-perl/Eval-Closure/Eval-Closure-0.130.0.ebuild
new file mode 100644
index 000000000000..a54d5d8c7b6c
--- /dev/null
+++ b/dev-perl/Eval-Closure/Eval-Closure-0.130.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=DOY
+MODULE_VERSION=0.13
+inherit perl-module
+
+DESCRIPTION="safely and cleanly create closures via string eval"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd ~x64-macos"
+IUSE="test minimal"
+
+# Scalar::Util -> Scalar-List-Utils
+RDEPEND="
+ virtual/perl-Carp
+ virtual/perl-Exporter
+ virtual/perl-Scalar-List-Utils
+ dev-perl/Try-Tiny
+ !minimal? (
+ >=dev-perl/Devel-LexAlias-0.50.0
+ dev-perl/perltidy
+ )
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ virtual/perl-File-Spec
+ virtual/perl-IO
+ dev-perl/Test-Fatal
+ dev-perl/Test-Requires
+ >=virtual/perl-Test-Simple-0.880.0
+ )
+"
+
+SRC_TEST="do"