summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/Exception-Warning')
-rw-r--r--dev-perl/Exception-Warning/Exception-Warning-0.40.100-r2.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-perl/Exception-Warning/Exception-Warning-0.40.100-r2.ebuild b/dev-perl/Exception-Warning/Exception-Warning-0.40.100-r2.ebuild
new file mode 100644
index 000000000000..4efdc3607e7c
--- /dev/null
+++ b/dev-perl/Exception-Warning/Exception-Warning-0.40.100-r2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=DEXTER
+DIST_VERSION=0.0401
+DIST_EXAMPLES=("eg/*")
+inherit perl-module
+
+DESCRIPTION="Convert simple warn into real exception object"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-perl/Exception-Base-0.210.0
+"
+DEPEND="dev-perl/Module-Build"
+BDEPEND="${RDEPEND}
+ dev-perl/Module-Build
+ test? (
+ >=dev-perl/Test-Assert-0.50.0
+ >=dev-perl/Test-Unit-Lite-0.120.0
+ virtual/perl-parent
+ )
+"