summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/HTML-Mason-PSGIHandler')
-rw-r--r--dev-perl/HTML-Mason-PSGIHandler/HTML-Mason-PSGIHandler-0.520.0.ebuild28
-rw-r--r--dev-perl/HTML-Mason-PSGIHandler/HTML-Mason-PSGIHandler-0.530.0.ebuild29
-rw-r--r--dev-perl/HTML-Mason-PSGIHandler/Manifest2
-rw-r--r--dev-perl/HTML-Mason-PSGIHandler/metadata.xml11
4 files changed, 70 insertions, 0 deletions
diff --git a/dev-perl/HTML-Mason-PSGIHandler/HTML-Mason-PSGIHandler-0.520.0.ebuild b/dev-perl/HTML-Mason-PSGIHandler/HTML-Mason-PSGIHandler-0.520.0.ebuild
new file mode 100644
index 000000000000..5e89eddbabce
--- /dev/null
+++ b/dev-perl/HTML-Mason-PSGIHandler/HTML-Mason-PSGIHandler-0.520.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=ABH
+MODULE_VERSION=0.52
+inherit perl-module
+
+DESCRIPTION="PSGI handler for HTML::Mason"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ dev-perl/CGI-PSGI
+ dev-perl/HTML-Mason
+"
+DEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.310.0
+ test? (
+ dev-perl/Plack
+ )
+"
+
+SRC_TEST=do
diff --git a/dev-perl/HTML-Mason-PSGIHandler/HTML-Mason-PSGIHandler-0.530.0.ebuild b/dev-perl/HTML-Mason-PSGIHandler/HTML-Mason-PSGIHandler-0.530.0.ebuild
new file mode 100644
index 000000000000..bde50c6f8d88
--- /dev/null
+++ b/dev-perl/HTML-Mason-PSGIHandler/HTML-Mason-PSGIHandler-0.530.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=RUZ
+MODULE_VERSION=0.53
+inherit perl-module
+
+DESCRIPTION="PSGI handler for HTML::Mason"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ dev-perl/CGI-PSGI
+ dev-perl/HTML-Mason
+"
+DEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.300.0
+ test? (
+ dev-perl/Plack
+ virtual/perl-Test-Simple
+ )
+"
+
+SRC_TEST="do parallel"
diff --git a/dev-perl/HTML-Mason-PSGIHandler/Manifest b/dev-perl/HTML-Mason-PSGIHandler/Manifest
new file mode 100644
index 000000000000..72284dc2b9b9
--- /dev/null
+++ b/dev-perl/HTML-Mason-PSGIHandler/Manifest
@@ -0,0 +1,2 @@
+DIST HTML-Mason-PSGIHandler-0.52.tar.gz 13167 SHA256 e48e4362f983871da804b497a7ac176d6bffb503ea958ae92c8fb768af967157 SHA512 92e24c9f7e66f995c76ab8fdc1e494006eb9c3680f9cd86012e96500e16f02c40c885d175ab1bc19d9f22f62cfa064c81ce5d075de3c6278c2a485b320c6db62 WHIRLPOOL 61b201ea5298aed063f41abd7abb002437cea5b70b7dd07839e0fe4dfef71189474b01ec46f0434c3f46c4f61f90af14495fee859aab6e3e6b977d8191b1cffe
+DIST HTML-Mason-PSGIHandler-0.53.tar.gz 14157 SHA256 eafd7c7655dfa8261df3446b931a283d30306877b83ac4671c49cff74ea7f00b SHA512 d8fe27ff0b25e41b7e64e83c277d323f5207b66e7630e3f688d586c375c63b1837935934a67e630c54fe8219e7b44fe084875e1530d36044fac85884ea62da40 WHIRLPOOL a3ee8c29eaec8aa8775a894542f645c7f037d5032111f65980f8bfc001d1152fd51be9505aab63ff86d2b75c8502d6e55d0a0054af0ec5dd074df9623892c4b5
diff --git a/dev-perl/HTML-Mason-PSGIHandler/metadata.xml b/dev-perl/HTML-Mason-PSGIHandler/metadata.xml
new file mode 100644
index 000000000000..933ccaa5fc70
--- /dev/null
+++ b/dev-perl/HTML-Mason-PSGIHandler/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>perl</herd>
+ <upstream>
+ <remote-id type="cpan">HTML-Mason-PSGIHandler</remote-id>
+ <remote-id type="cpan-module">HTML::Mason::PSGIHandler</remote-id>
+ <remote-id type="cpan-module">HTML::Mason::PSGIHandler::Streamy</remote-id>
+ <remote-id type="cpan-module">HTML::Mason::Request::PSGI</remote-id>
+ </upstream>
+</pkgmetadata>