summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/Net-SMTP-SSL/Net-SMTP-SSL-1.40.0.ebuild')
-rw-r--r--dev-perl/Net-SMTP-SSL/Net-SMTP-SSL-1.40.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-perl/Net-SMTP-SSL/Net-SMTP-SSL-1.40.0.ebuild b/dev-perl/Net-SMTP-SSL/Net-SMTP-SSL-1.40.0.ebuild
new file mode 100644
index 000000000000..5c0979c1aeae
--- /dev/null
+++ b/dev-perl/Net-SMTP-SSL/Net-SMTP-SSL-1.40.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=RJBS
+DIST_VERSION=1.04
+inherit perl-module
+
+DESCRIPTION="(Deprecated) SSL support for Net::SMTP"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="test"
+
+RDEPEND="
+ virtual/perl-libnet
+ dev-perl/IO-Socket-SSL
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? ( >=virtual/perl-Test-Simple-0.470.0 )
+"
+
+pkg_postinst() {
+ elog "This package is deprecated by upstream as equivalent support for SSL and"
+ elog "STARTTLS is available with Net::SMTP 2.35, found in:"
+ elog " >=virtual/perl-libnet-1.28 ( >=dev-lang/perl-5.20.0 )"
+ elog "Subsequently, this package is only available for compatibility reasons, and"
+ elog "should be avoided in new code."
+}