summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/Net-UPnP/Net-UPnP-1.4.3.ebuild')
-rw-r--r--dev-perl/Net-UPnP/Net-UPnP-1.4.3.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-perl/Net-UPnP/Net-UPnP-1.4.3.ebuild b/dev-perl/Net-UPnP/Net-UPnP-1.4.3.ebuild
new file mode 100644
index 000000000000..32a5b21146b7
--- /dev/null
+++ b/dev-perl/Net-UPnP/Net-UPnP-1.4.3.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DIST_AUTHOR=SKONNO
+inherit perl-module
+
+DESCRIPTION="Perl extension for UPnP"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-solaris"
+# Package warrants IUSE examples
+IUSE="examples test"
+
+RDEPEND="virtual/perl-version"
+DEPEND="${RDEPEND}
+ dev-perl/Module-Build
+ test? ( virtual/perl-Test-Simple )
+"
+src_install() {
+ perl-module_src_install
+ if use examples; then
+ dodir usr/share/doc/${PF}/examples
+ docompress -x usr/share/doc/${PF}/examples
+ insinto usr/share/doc/${PF}/
+ doins -r examples/
+ fi
+}