summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-php/PEAR-File_Archive/PEAR-File_Archive-1.5.5-r1.ebuild')
-rw-r--r--dev-php/PEAR-File_Archive/PEAR-File_Archive-1.5.5-r1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-php/PEAR-File_Archive/PEAR-File_Archive-1.5.5-r1.ebuild b/dev-php/PEAR-File_Archive/PEAR-File_Archive-1.5.5-r1.ebuild
new file mode 100644
index 000000000000..81b3e4f31ea5
--- /dev/null
+++ b/dev-php/PEAR-File_Archive/PEAR-File_Archive-1.5.5-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+MY_PN="${PN/PEAR-/}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Easily manipulate archives in PHP"
+HOMEPAGE="http://pear.php.net/package/${MY_PN}"
+SRC_URI="http://download.pear.php.net/package/${MY_P}.tgz"
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="minimal"
+
+RDEPEND="dev-lang/php[bzip2,zlib]
+ dev-php/PEAR-MIME_Type
+ dev-php/PEAR-PEAR
+ !minimal? (
+ dev-php/PEAR-Mail_Mime
+ dev-php/PEAR-Mail
+ dev-php/PEAR-Cache_Lite
+ )"
+
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+ dodoc README
+
+ insinto /usr/share/php
+ doins -r File
+}