summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-php/adodb/adodb-5.20.17.ebuild')
-rw-r--r--dev-php/adodb/adodb-5.20.17.ebuild40
1 files changed, 0 insertions, 40 deletions
diff --git a/dev-php/adodb/adodb-5.20.17.ebuild b/dev-php/adodb/adodb-5.20.17.ebuild
deleted file mode 100644
index a1cd6765bdcf..000000000000
--- a/dev-php/adodb/adodb-5.20.17.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-MY_PN="ADOdb"
-DESCRIPTION="Database abstraction layer for PHP"
-HOMEPAGE="https://github.com/ADOdb"
-SRC_URI="https://github.com/${MY_PN}/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD LGPL-2.1+"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
-IUSE=""
-
-# If you want to be picky, we should require that PHP be built with at
-# least one database driver enabled; otherwise adodb isn't going to be
-# able to do anything. But, the database USE flags for dev-lang/php are
-# a mess. What we would *like* to do is have a set of USE flags for
-# adodb that then propagate to PHP itself... for example, adodb[mysql]
-# could require php[mysql]. To do that would require that we duplicate
-# the database USE flag mess for adodb -- not desirable. Instead we punt
-# and let the user install adodb unconditionally. If he doesn't have
-# database support in PHP, it just won't work.
-RDEPEND="dev-lang/php:*"
-
-S="${WORKDIR}/${MY_PN}-${PV}"
-
-src_install() {
- DOCS="README.md docs/changelog*.md xmlschema*.dtd session/*.sql"
- DOCS+=" session/*.txt session/*.xml pear/auth_adodb_example.php"
- DOCS+=" pear/readme.Auth.txt"
-
- dodoc $DOCS
- rm -f $DOCS || die "failed to remove docs before installation"
-
- insinto "/usr/share/php/${PN}"
- doins *.php
- doins -r contrib datadict drivers lang pear perf replicate session xsl
-}