summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-php/pecl-xdiff/pecl-xdiff-1.5.2-r5.ebuild')
-rw-r--r--dev-php/pecl-xdiff/pecl-xdiff-1.5.2-r5.ebuild48
1 files changed, 0 insertions, 48 deletions
diff --git a/dev-php/pecl-xdiff/pecl-xdiff-1.5.2-r5.ebuild b/dev-php/pecl-xdiff/pecl-xdiff-1.5.2-r5.ebuild
deleted file mode 100644
index 4a9ca4d80720..000000000000
--- a/dev-php/pecl-xdiff/pecl-xdiff-1.5.2-r5.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PHP_EXT_NAME="xdiff"
-PHP_EXT_PECL_PKG="xdiff"
-DOCS=( README.API )
-
-USE_PHP="php5-6 php7-0 php7-1"
-
-inherit php-ext-pecl-r3
-
-USE_PHP="php5-6"
-
-KEYWORDS="~amd64 ~x86"
-
-DESCRIPTION="PHP extension for generating diff files"
-LICENSE="PHP-3.01"
-SLOT="0"
-
-DEPEND="php_targets_php5-6? ( dev-libs/libxdiff )"
-RDEPEND="${DEPEND}"
-PDEPEND="
-php_targets_php7-0? ( dev-php/pecl-xdiff:7[php_targets_php7-0] )
-php_targets_php7-1? ( dev-php/pecl-xdiff:7[php_targets_php7-1] )
-"
-
-src_prepare() {
- if use php_targets_php5-6 ; then
- php-ext-source-r3_src_prepare
- else
- eapply_user
- fi
-}
-
-src_configure() {
- if use php_targets_php5-6 ; then
- local PHP_EXT_ECONF_ARGS=()
- php-ext-source-r3_src_configure
- fi
-}
-
-src_install() {
- if use php_targets_php5-6 ; then
- php-ext-pecl-r3_src_install
- fi
-}