summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-php/webmozart-assert/webmozart-assert-1.4.0.ebuild')
-rw-r--r--dev-php/webmozart-assert/webmozart-assert-1.4.0.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-php/webmozart-assert/webmozart-assert-1.4.0.ebuild b/dev-php/webmozart-assert/webmozart-assert-1.4.0.ebuild
new file mode 100644
index 000000000000..77df9aa06b41
--- /dev/null
+++ b/dev-php/webmozart-assert/webmozart-assert-1.4.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+MY_PN="${PN/webmozart-//}"
+
+DESCRIPTION="Assertions to validate method input/output with nice error messages"
+HOMEPAGE="https://github.com/webmozart/assert"
+SRC_URI="https://github.com/webmozart/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+RDEPEND="dev-php/fedora-autoloader
+ >=dev-lang/php-5.6:*"
+
+src_install() {
+ insinto /usr/share/php/Webmozart/Assert
+ doins -r src/*
+ doins "${FILESDIR}/autoload.php"
+}