summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/SchemaObject/SchemaObject-0.5.3.ebuild')
-rw-r--r--dev-python/SchemaObject/SchemaObject-0.5.3.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/SchemaObject/SchemaObject-0.5.3.ebuild b/dev-python/SchemaObject/SchemaObject-0.5.3.ebuild
new file mode 100644
index 000000000000..5cb07d3f8834
--- /dev/null
+++ b/dev-python/SchemaObject/SchemaObject-0.5.3.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+PYTHON_DEPEND="2:2.5:2.7"
+
+inherit distutils
+
+DESCRIPTION="A simple Python object interface to a MySQL database schema"
+HOMEPAGE="http://matuson.com/code/schemaobject/"
+SRC_URI="http://www.matuson.com/code/schemaobject/downloads/${P}.tar.gz"
+
+pn="${PN,,}"
+S="${WORKDIR}/${pn}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ python_convert_shebangs -r 2 .
+}
+
+pkg_postinst() {
+ python_mod_optimize "${pn}"
+}
+
+pkg_postrm() {
+ python_mod_cleanup "${pn}"
+}