summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/aiofiles')
-rw-r--r--dev-python/aiofiles/Manifest3
-rw-r--r--dev-python/aiofiles/aiofiles-0.4.0.ebuild24
-rw-r--r--dev-python/aiofiles/aiofiles-0.5.0.ebuild24
-rw-r--r--dev-python/aiofiles/aiofiles-23.2.1.ebuild27
-rw-r--r--dev-python/aiofiles/metadata.xml12
5 files changed, 33 insertions, 57 deletions
diff --git a/dev-python/aiofiles/Manifest b/dev-python/aiofiles/Manifest
index 601a81ef32ad..d0942ccbe9b5 100644
--- a/dev-python/aiofiles/Manifest
+++ b/dev-python/aiofiles/Manifest
@@ -1,2 +1 @@
-DIST aiofiles-0.4.0.tar.gz 12942 BLAKE2B c8e6570f0759cf97b642a8feec4a572dc40a86906c9f7e749fa5b20346b61000d62d72c1ef8316e03adc1352021ec622fe9c670e916fdf84f41845ce37f1de51 SHA512 9e1f8b2beb3ca2996b35de9281ceafbb8ccdeab4b213f9605cb5908558c5f495d1cf4481ac229ca44bb236ad99826d89d137ec6ac4386c23b6e056b657a6bf4a
-DIST aiofiles-0.5.0.tar.gz 13332 BLAKE2B ccd044ce9fcd74b2a6419b4f0e9e3977086c9685741dbb734a7f9222ab96dca58b5330ad0d0cd9f10fce03ee123add7101825f047451344fc451c40a4352674e SHA512 89eb1af506bdf5f3f2e9c3afe90f17d521ada1cdeb449dcdc800d4faa4edc1c9ca93811915aa059d8c5a1b0a3aaa40231a46b3d041ca745e071628293bddf1b7
+DIST aiofiles-23.2.1.tar.gz 32072 BLAKE2B 9718fe7f4367b30ca295efb39ffeab0c77ca54ed1c4f556b0b39f5abb540d4f23c6e8a49aa5b6b76c0692e393bbab7c8d252de4b0f6f4f423b74e88c43483e08 SHA512 defc9d1ff5351c1812432db1849233b1f0aa661f6420c79a6eb17d84c0622ee4dd5102d50e9ef920c91adcc48914a39cd62701b340b01806a83773bf05900b6f
diff --git a/dev-python/aiofiles/aiofiles-0.4.0.ebuild b/dev-python/aiofiles/aiofiles-0.4.0.ebuild
deleted file mode 100644
index 986e5ea1c6ff..000000000000
--- a/dev-python/aiofiles/aiofiles-0.4.0.ebuild
+++ /dev/null
@@ -1,24 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-DISTUTILS_USE_SETUPTOOLS=bdepend
-PYTHON_COMPAT=( python3_{6,7,8} )
-
-inherit distutils-r1
-
-DESCRIPTION="File support for asyncio"
-HOMEPAGE="https://github.com/Tinche/aiofiles"
-SRC_URI="https://github.com/Tinche/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-DEPEND="test? (
- >=dev-python/pytest-5.4[${PYTHON_USEDEP}]
- dev-python/pytest-asyncio[${PYTHON_USEDEP}]
-)"
-
-distutils_enable_tests pytest
diff --git a/dev-python/aiofiles/aiofiles-0.5.0.ebuild b/dev-python/aiofiles/aiofiles-0.5.0.ebuild
deleted file mode 100644
index 986e5ea1c6ff..000000000000
--- a/dev-python/aiofiles/aiofiles-0.5.0.ebuild
+++ /dev/null
@@ -1,24 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-DISTUTILS_USE_SETUPTOOLS=bdepend
-PYTHON_COMPAT=( python3_{6,7,8} )
-
-inherit distutils-r1
-
-DESCRIPTION="File support for asyncio"
-HOMEPAGE="https://github.com/Tinche/aiofiles"
-SRC_URI="https://github.com/Tinche/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-DEPEND="test? (
- >=dev-python/pytest-5.4[${PYTHON_USEDEP}]
- dev-python/pytest-asyncio[${PYTHON_USEDEP}]
-)"
-
-distutils_enable_tests pytest
diff --git a/dev-python/aiofiles/aiofiles-23.2.1.ebuild b/dev-python/aiofiles/aiofiles-23.2.1.ebuild
new file mode 100644
index 000000000000..ed9870a2b8d8
--- /dev/null
+++ b/dev-python/aiofiles/aiofiles-23.2.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="File support for asyncio"
+HOMEPAGE="
+ https://github.com/Tinche/aiofiles/
+ https://pypi.org/project/aiofiles/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~loong ppc ppc64 ~riscv ~s390 sparc x86"
+
+BDEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
diff --git a/dev-python/aiofiles/metadata.xml b/dev-python/aiofiles/metadata.xml
index 83d73c6d0c04..b7130989dcd5 100644
--- a/dev-python/aiofiles/metadata.xml
+++ b/dev-python/aiofiles/metadata.xml
@@ -1,16 +1,14 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer type="person">
- <email>onigino@protonmail.com</email>
- <name>Gino McCarty</name>
- </maintainer>
<maintainer type="project">
- <email>proxy-maint@gentoo.org</email>
- <name>Proxy Maintainers</name>
+ <email>python@gentoo.org</email>
+ <name>Python</name>
</maintainer>
+ <stabilize-allarches/>
<upstream>
<remote-id type="github">Tinche/aiofiles</remote-id>
<bugs-to>https://github.com/Tinche/aiofiles/issues</bugs-to>
+ <remote-id type="pypi">aiofiles</remote-id>
</upstream>
</pkgmetadata>