summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/amqplib')
-rw-r--r--dev-python/amqplib/Manifest1
-rw-r--r--dev-python/amqplib/amqplib-1.0.2-r1.ebuild41
-rw-r--r--dev-python/amqplib/files/amqplib-0.6.1_disable_socket_tests.patch17
-rw-r--r--dev-python/amqplib/files/amqplib-1.0.2-unicode_tests_py3.patch63
-rw-r--r--dev-python/amqplib/metadata.xml16
5 files changed, 0 insertions, 138 deletions
diff --git a/dev-python/amqplib/Manifest b/dev-python/amqplib/Manifest
deleted file mode 100644
index e5b368fa5a47..000000000000
--- a/dev-python/amqplib/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST amqplib-1.0.2.tgz 58544 BLAKE2B fed0cc178042467ae4e73d197dd1f2819725236274aa5951d67f7277825b851425712c96b5b1fd95010e47310746bc5b903f8858777f8999a9d310b675d60a11 SHA512 6c8c9fd7fd68fd6a1eb944962094e57f89525bc78dd002dc0dadd491b262293367a86569dfc52f0701723b4327b7c290150dc2e69e3ac1a28613578d9e0d0710
diff --git a/dev-python/amqplib/amqplib-1.0.2-r1.ebuild b/dev-python/amqplib/amqplib-1.0.2-r1.ebuild
deleted file mode 100644
index d8df30715207..000000000000
--- a/dev-python/amqplib/amqplib-1.0.2-r1.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-PYTHON_COMPAT=( python3_6 )
-
-inherit distutils-r1
-
-DESCRIPTION="Python client for the Advanced Message Queuing Procotol (AMQP)"
-HOMEPAGE="https://barryp.org/software/py-amqplib/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tgz"
-
-LICENSE="LGPL-3"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 x86"
-IUSE="examples extras test"
-RESTRICT="!test? ( test )"
-
-PATCHES=(
- "${FILESDIR}/${PN}-0.6.1_disable_socket_tests.patch"
- "${FILESDIR}/${P}-unicode_tests_py3.patch"
-)
-
-python_test() {
- "${PYTHON}" tests/client_0_8/run_all.py \
- || die "Tests fail with ${EPYTHON}"
-}
-
-python_install_all() {
- distutils-r1_python_install_all
-
- dodoc -r docs/.
- if use examples; then
- docinto examples
- dodoc -r demo/.
- fi
- if use extras; then
- insinto /usr/share/${PF}
- doins -r extras
- fi
-}
diff --git a/dev-python/amqplib/files/amqplib-0.6.1_disable_socket_tests.patch b/dev-python/amqplib/files/amqplib-0.6.1_disable_socket_tests.patch
deleted file mode 100644
index c92e3cba64f4..000000000000
--- a/dev-python/amqplib/files/amqplib-0.6.1_disable_socket_tests.patch
+++ /dev/null
@@ -1,17 +0,0 @@
-diff -uNr amqplib-0.6.1.org/tests/client_0_8/run_all.py amqplib-0.6.1/tests/client_0_8/run_all.py
---- amqplib-0.6.1.org/tests/client_0_8/run_all.py 2011-07-06 16:21:22.000000000 -0400
-+++ amqplib-0.6.1/tests/client_0_8/run_all.py 2011-07-06 16:21:38.000000000 -0400
-@@ -28,13 +28,8 @@
- 'test_exceptions',
- 'test_serialization',
- 'test_basic_message',
-- 'test_connection',
-- 'test_channel',
- ]
-
--if sys.version_info >= (2, 5):
-- TEST_NAMES.append('test_with')
--
- def main():
- suite = unittest.TestLoader().loadTestsFromNames(TEST_NAMES)
- unittest.TextTestRunner(**settings.test_args).run(suite)
diff --git a/dev-python/amqplib/files/amqplib-1.0.2-unicode_tests_py3.patch b/dev-python/amqplib/files/amqplib-1.0.2-unicode_tests_py3.patch
deleted file mode 100644
index 14252a678203..000000000000
--- a/dev-python/amqplib/files/amqplib-1.0.2-unicode_tests_py3.patch
+++ /dev/null
@@ -1,63 +0,0 @@
---- a/tests/client_0_8/test_serialization.py 2011-07-18 00:11:48.000000000 -0400
-+++ b/tests/client_0_8/test_serialization.py 2012-03-02 16:54:35.000000000 -0500
-@@ -32,6 +32,18 @@
- # Python 2.5 and lower
- bytes = str
-
-+#Unicode Strings for py3 tests
-+uni_strings = {
-+ 'u0100' : '\u0100',
-+ 'hello' : 'hello',
-+ 'a' : 'a',
-+ 'another' : 'And something in unicode'
-+}
-+
-+if hasattr(str, 'decode'):
-+ for wk, wv in uni_strings.iteritems():
-+ uni_strings[wk] = wv.decode("utf-8")
-+
- import settings
-
- from amqplib.client_0_8.serialization import AMQPReader, AMQPWriter, GenericContent
-@@ -232,12 +244,12 @@
-
- def test_shortstr_unicode(self):
- w = AMQPWriter()
-- w.write_shortstr(u'hello')
-+ w.write_shortstr(uni_strings['hello'])
- s = w.getvalue()
- self.assertEqualBinary(s, '\x05hello')
-
- r = AMQPReader(s)
-- self.assertEqual(r.read_shortstr(), u'hello')
-+ self.assertEqual(r.read_shortstr(),uni_strings['hello'])
-
- def test_long_shortstr(self):
- w = AMQPWriter()
-@@ -245,7 +257,7 @@
-
- def test_long_shortstr_unicode(self):
- w = AMQPWriter()
-- self.assertRaises(ValueError, w.write_shortstr, u'\u0100' * 128)
-+ self.assertRaises(ValueError, w.write_shortstr, uni_strings['u0100'] * 128)
-
-
- #
-@@ -273,7 +285,7 @@
- self.assertEqual(r.read_longstr(), str(val))
-
- def test_longstr_unicode(self):
-- val = u'a' * 512
-+ val = uni_strings['a'] * 512
- w = AMQPWriter()
- w.write_longstr(val)
- s = w.getvalue()
-@@ -324,7 +336,7 @@
- 'foo': 7,
- 'bar': Decimal('123345.1234'),
- 'baz': 'this is some random string I typed',
-- 'ubaz': u'And something in unicode',
-+ 'ubaz': uni_strings['another'],
- 'dday_aniv': datetime(1994, 6, 6),
- 'more': {
- 'abc': -123,
diff --git a/dev-python/amqplib/metadata.xml b/dev-python/amqplib/metadata.xml
deleted file mode 100644
index 1846993fbe99..000000000000
--- a/dev-python/amqplib/metadata.xml
+++ /dev/null
@@ -1,16 +0,0 @@
-<?xml version='1.0' encoding='UTF-8'?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>python@gentoo.org</email>
- <name>Python</name>
- </maintainer>
- <use>
- <flag name="extras">Install extra tools to generate initial Python mod
- from an AMQP XML file</flag>
- </use>
- <upstream>
- <remote-id type="google-code">py-amqplib</remote-id>
- <remote-id type="pypi">amqplib</remote-id>
- </upstream>
-</pkgmetadata>