summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/appdirs/appdirs-1.4.0.ebuild')
-rw-r--r--dev-python/appdirs/appdirs-1.4.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/appdirs/appdirs-1.4.0.ebuild b/dev-python/appdirs/appdirs-1.4.0.ebuild
new file mode 100644
index 000000000000..2ca055f8c360
--- /dev/null
+++ b/dev-python/appdirs/appdirs-1.4.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Module for determining appropriate platform-specific dirs"
+HOMEPAGE="http://github.com/ActiveState/appdirs"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+# api.doctests is missing in the dist zipfile
+# and the 'internal' doctest does nothing
+RESTRICT=test
+
+python_test() {
+ cd test || die
+ "${PYTHON}" test.py \
+ || die "Tests fail with ${EPYTHON}"
+}