summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/appdirs/files/appdirs-1.4.0-distutils.patch')
-rw-r--r--dev-python/appdirs/files/appdirs-1.4.0-distutils.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/appdirs/files/appdirs-1.4.0-distutils.patch b/dev-python/appdirs/files/appdirs-1.4.0-distutils.patch
new file mode 100644
index 000000000000..eb0cf8217545
--- /dev/null
+++ b/dev-python/appdirs/files/appdirs-1.4.0-distutils.patch
@@ -0,0 +1,22 @@
+Force setup.py to use distutils in order to break setuptools cyclic dependency.
+
+--- appdirs-1.4.0/setup.py
++++ appdirs-1.4.0/setup.py
+@@ -2,7 +2,7 @@
+ import sys
+ import os
+ import os.path
+-from setuptools import setup
++from distutils.core import setup
+ import appdirs
+
+ tests_require = []
+@@ -38,8 +38,6 @@
+ Programming Language :: Python :: 3.2
+ Topic :: Software Development :: Libraries :: Python Modules
+ """.split('\n') if c.strip()],
+- test_suite='test.test_api',
+- tests_require=tests_require,
+ keywords='application directory log cache user',
+ author='Trent Mick',
+ author_email='trentm@gmail.com',