summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/arrayterator/arrayterator-1.0.1-r1.ebuild')
-rw-r--r--dev-python/arrayterator/arrayterator-1.0.1-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/arrayterator/arrayterator-1.0.1-r1.ebuild b/dev-python/arrayterator/arrayterator-1.0.1-r1.ebuild
new file mode 100644
index 000000000000..7ccba61858ee
--- /dev/null
+++ b/dev-python/arrayterator/arrayterator-1.0.1-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="A buffered iterator for reading big arrays in small contiguous blocks"
+HOMEPAGE="http://pypi.python.org/pypi/arrayterator"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64"
+IUSE=""
+
+RDEPEND=">=dev-python/numpy-1.0_rc1[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ cd tests || die
+
+ "${PYTHON}" -c "import test_stochastic; test_stochastic.test()" \
+ || die "Tests fail with ${EPYTHON}"
+}