summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/awscli/awscli-1.10.42.ebuild')
-rw-r--r--dev-python/awscli/awscli-1.10.42.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/awscli/awscli-1.10.42.ebuild b/dev-python/awscli/awscli-1.10.42.ebuild
new file mode 100644
index 000000000000..f1631b5ae3ce
--- /dev/null
+++ b/dev-python/awscli/awscli-1.10.42.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Universal Command Line Environment for AWS"
+HOMEPAGE="http://pypi.python.org/pypi/awscli"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="
+ dev-python/botocore[${PYTHON_USEDEP}]
+ <=dev-python/colorama-0.3.3[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ <=dev-python/rsa-3.5.0[${PYTHON_USEDEP}]
+ dev-python/s3transfer[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ "