summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/babelfish/babelfish-9999.ebuild')
-rw-r--r--dev-python/babelfish/babelfish-9999.ebuild21
1 files changed, 7 insertions, 14 deletions
diff --git a/dev-python/babelfish/babelfish-9999.ebuild b/dev-python/babelfish/babelfish-9999.ebuild
index cbf34c9a656d..e754bb9de0ae 100644
--- a/dev-python/babelfish/babelfish-9999.ebuild
+++ b/dev-python/babelfish/babelfish-9999.ebuild
@@ -2,30 +2,23 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI="5"
-PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+EAPI=6
-if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="https://github.com/Diaoul/babelfish.git"
- inherit git-r3
-else
- SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
- KEYWORDS="~amd64 ~x86"
-fi
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
-inherit distutils-r1
+inherit distutils-r1 git-r3
DESCRIPTION="Python library to work with countries and languages"
HOMEPAGE="https://github.com/Diaoul/babelfish https://pypi.python.org/pypi/babelfish"
+EGIT_REPO_URI="git://github.com/Diaoul/${PN}.git"
LICENSE="BSD"
SLOT="0"
+KEYWORDS=""
IUSE=""
-RDEPEND=""
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
-"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
python_test() {
esetup.py test