summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/behave')
-rw-r--r--dev-python/behave/Manifest2
-rw-r--r--dev-python/behave/behave-1.2.4.ebuild58
-rw-r--r--dev-python/behave/behave-1.2.5.ebuild53
-rw-r--r--dev-python/behave/metadata.xml14
4 files changed, 127 insertions, 0 deletions
diff --git a/dev-python/behave/Manifest b/dev-python/behave/Manifest
new file mode 100644
index 000000000000..db4416d0de7e
--- /dev/null
+++ b/dev-python/behave/Manifest
@@ -0,0 +1,2 @@
+DIST behave-1.2.4.tar.gz 343050 SHA256 24542aadd9eeb3a471076f9d880a69250052153df93122d9991938db917759ec SHA512 98360202fdccaa6cdfaf70a2a658db06b8de0017fbaeb5bd8d33ae8f009444a29f9e75eab8a4b363eb7719ef10566fad5521372285f2998cfb6e3037df706a1c WHIRLPOOL 2278500709733f9715ada2e6e178d6bb32c566c8df8ae6bc8ac3400ec66e37d9a1559c58e869becc89a8861407c658f22c695416d3617d7651629a5f2eadd6b5
+DIST behave-1.2.5.tar.gz 385738 SHA256 81b731ac5187e31e4aad2594944fa914943683a9818320846d037c5ebd6d5d0b SHA512 137ede0baed9df154087249df8dcae81ab0cdf1de91a5790fca7ccf3231ba2ba4e64623abd2b8c9bfc459ab6575f68b9ef7e03e33ef79e524d9443a8489ec7fe WHIRLPOOL 07b603da98220f35d82f11ea07042e5962c6be4ba1442c27a491c00b3260a57880bb26fbf89b510d898457675be28e63ff0c37dd5568d5905ff5e41ccb4b400d
diff --git a/dev-python/behave/behave-1.2.4.ebuild b/dev-python/behave/behave-1.2.4.ebuild
new file mode 100644
index 000000000000..a3ab59c8ed45
--- /dev/null
+++ b/dev-python/behave/behave-1.2.4.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="behaviour-driven development, Python style"
+HOMEPAGE="http://github.com/behave/behave"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc test"
+
+DEPEND="
+ doc? (
+ >=dev-python/sphinx-1.2.2[${PYTHON_USEDEP}]
+ >=dev-python/sphinxcontrib-cheeseshop-0.2[${PYTHON_USEDEP}]
+ )
+ test? (
+ >=dev-python/mock-1.0[${PYTHON_USEDEP}]
+ >=dev-python/nose-1.1[${PYTHON_USEDEP}]
+ >=dev-python/pyhamcrest-1.8[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="
+ >=dev-python/parse-1.6.3[${PYTHON_USEDEP}]
+ >=dev-python/parse-type-0.3.4[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ nosetests || die "nosetests failed under ${EPYTHON}"
+
+ local DISTUTILS_NO_PARALLEL_BUILD=TRUE
+
+ rm -f "${HOME}"/.pydistutils.cfg || die "Couldn't remove pydistutils.cfg"
+
+ distutils_install_for_testing
+
+ ${TEST_DIR}/scripts/behave -f progress --junit --tags=~@xfail features/ || die "behave features failed under ${EPYTHON}"
+ ${TEST_DIR}/scripts/behave -f progress --junit --tags=~@xfail tools/test-features/ || die "behave test-festures failed under ${EPYTHON}"
+ ${TEST_DIR}/scripts/behave -f progress --junit --tags=~@xfail issue.features/ || die "behave issue.features failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( build/docs/html/. )
+
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/behave/behave-1.2.5.ebuild b/dev-python/behave/behave-1.2.5.ebuild
new file mode 100644
index 000000000000..3b0198268960
--- /dev/null
+++ b/dev-python/behave/behave-1.2.5.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_3 python3_4 )
+
+inherit distutils-r1
+
+DESCRIPTION="behaviour-driven development, Python style"
+HOMEPAGE="http://github.com/behave/behave"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? (
+ >=dev-python/sphinx-1.2.2[${PYTHON_USEDEP}]
+ >=dev-python/sphinxcontrib-cheeseshop-0.2[${PYTHON_USEDEP}]
+ )
+ test? (
+ >=dev-python/mock-1.0[${PYTHON_USEDEP}]
+ >=dev-python/nose-1.3[${PYTHON_USEDEP}]
+ >=dev-python/pyhamcrest-1.8[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="
+ >=dev-python/parse-1.6.3[${PYTHON_USEDEP}]
+ >=dev-python/parse-type-0.3.4[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ nosetests || die "nosetests failed under ${EPYTHON}"
+
+ ${PYTHON} -m behave --tags='~@xfail' features/ || die "behave features failed under ${EPYTHON}"
+ ${PYTHON} -m behave --tags='~@xfail' tools/test-features/ || die "behave test-festures failed under ${EPYTHON}"
+ ${PYTHON} -m behave --tags='~@xfail' issue.features/ || die "behave issue.features failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( build/docs/html/. )
+
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/behave/metadata.xml b/dev-python/behave/metadata.xml
new file mode 100644
index 000000000000..23aec91ad38d
--- /dev/null
+++ b/dev-python/behave/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>alunduil@gentoo.org</email>
+ <name>Alex Brandt</name>
+ </maintainer>
+ <longdescription lang="en">
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">behave</remote-id>
+ <remote-id type="github">behave/behave</remote-id>
+ </upstream>
+</pkgmetadata>