summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/bitstring/bitstring-3.1.1.ebuild')
-rw-r--r--dev-python/bitstring/bitstring-3.1.1.ebuild29
1 files changed, 0 insertions, 29 deletions
diff --git a/dev-python/bitstring/bitstring-3.1.1.ebuild b/dev-python/bitstring/bitstring-3.1.1.ebuild
deleted file mode 100644
index 6681e9c227a4..000000000000
--- a/dev-python/bitstring/bitstring-3.1.1.ebuild
+++ /dev/null
@@ -1,29 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-PYTHON_COMPAT=( python{2_7,3_4} )
-inherit distutils-r1
-
-DESCRIPTION="A pure Python module for creation and analysis of binary data"
-HOMEPAGE="https://python-bitstring.googlecode.com/"
-SRC_URI="https://python-bitstring.googlecode.com/files/${P}.zip"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="test"
-DEPEND="app-arch/unzip"
-RDEPEND=""
-
-python_test() {
- if [[ ${EPYTHON} == python2.6 ]]; then
- local runner=( unit2.py )
- else
- local runner=( "${PYTHON}" -m unittest )
- fi
- pushd test > /dev/null || die
- "${runner[@]}" discover || die "Testing failed with ${EPYTHON}"
- popd test > /dev/null || die
-}