summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/bokeh/bokeh-0.11.0.ebuild')
-rw-r--r--dev-python/bokeh/bokeh-0.11.0.ebuild15
1 files changed, 6 insertions, 9 deletions
diff --git a/dev-python/bokeh/bokeh-0.11.0.ebuild b/dev-python/bokeh/bokeh-0.11.0.ebuild
index bb275620812b..f64ab76ccaad 100644
--- a/dev-python/bokeh/bokeh-0.11.0.ebuild
+++ b/dev-python/bokeh/bokeh-0.11.0.ebuild
@@ -42,17 +42,14 @@ RDEPEND="
DEPEND="${REDEPEND}
dev-python/setuptools[${PYTHON_USEDEP}]
test? (
- dev-python/nose[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '>=dev-python/mock-1.0.1[${PYTHON_USEDEP}]' python2_7)
- )
- "
+ dev-python/pytest[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '>=dev-python/mock-1.0.1[${PYTHON_USEDEP}]' 'python2*')
+ $(python_gen_cond_dep 'dev-python/flexx[${PYTHON_USEDEP}]' 'python3*')
+ )"
+
python_test() {
cd "${BUILD_DIR}"/lib || die
- # exclude server tests for now
- nosetests -v \
- -e multiuser_auth_test \
- -e usermodel_test \
- || die
+ py.test -m 'not (js or examples or integration)' -vv || die
}
python_install_all() {