summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/boto')
-rw-r--r--dev-python/boto/Manifest5
-rw-r--r--dev-python/boto/boto-2.27.0.ebuild25
-rw-r--r--dev-python/boto/boto-2.31.1.ebuild25
-rw-r--r--dev-python/boto/boto-2.34.0.ebuild25
-rw-r--r--dev-python/boto/boto-2.35.1.ebuild27
-rw-r--r--dev-python/boto/boto-2.38.0.ebuild48
-rw-r--r--dev-python/boto/metadata.xml13
7 files changed, 168 insertions, 0 deletions
diff --git a/dev-python/boto/Manifest b/dev-python/boto/Manifest
new file mode 100644
index 000000000000..c09f071fe681
--- /dev/null
+++ b/dev-python/boto/Manifest
@@ -0,0 +1,5 @@
+DIST boto-2.27.0.tar.gz 6789802 SHA256 5b20c6c22177c8048b4299bed7c357b6418932abd434c277c5b6050a18dc284b SHA512 56caf13c0e9ccfe13a36f986f69f4f5630c4ced7558adb9a982bad4cad63828a958fcf7406954a3311ab0b5654c9804739655a121f82e661f1dc3db065529e54 WHIRLPOOL 9404b92a33b20d376a14a57a64df9c71382a17d1bde51a9674c526f9d3f4c988b25fc493dfdb844bf664587d18e5a749774f21f35694d1d9983ae3d18b32f3d8
+DIST boto-2.31.1.tar.gz 7078455 SHA256 dadccbe69a9f8d858506bb9b14ff288fa91b81dec1fefd8867792324b8cb33f3 SHA512 473f8c83dfe73ee9d5a3cb694793b99543264a7ef3b54346d11a5136e8b26b40fb8b1d7c9a23deaf34fb962ddf90923c6399f7cc3c8d6a1f5aa492d9a070393c WHIRLPOOL 6ac0cf73c4216ef18cecf591c7108651f1e1636d6863c5f31378965e9f7453dc42b36de032bcdee7956ba98694e1e706ef086df6923782b6266b5f9e09a072a9
+DIST boto-2.34.0.tar.gz 7302242 SHA256 33baab022ecb803414ad0d6cf4041d010cfc2755ff8acc3bea7b32e77ba98be0 SHA512 5784ab3eb785784fa348f9f572d8e885d297d0e569f503229f0ae3aa66389699c9fe21cd1737e20a9683735dc4e7a765aa2345b013c75a3292ed5995f20699d2 WHIRLPOOL 33c42d3f012410e9f3acead7293073dfea3e97cffa93248d735a76266480ab912935d8300839ef742820f1ed1a093dbf5555c163bd8ee34cf28f09a62a01dff5
+DIST boto-2.35.1.tar.gz 1367029 SHA256 62604f0fdf68a2b9a6c6bd5111c82e10281b498695152d21f56c9e4a0691d45d SHA512 4be15cbb4ccc9f984fed11213ce1e64fefe7adbc747314dc0030928f2876b55322344f325228d95209e0411ef22fe1a3bede91ffbf3e9eed1a1a2d2507bff92d WHIRLPOOL 060f3e2483a3a5be26b67a2a94df2f88a9eccb3f62cc4020e26b7ac0111d30d938638641f4c83c71095602d5b79e365de6211f884b4adbeacf6d7187bb04d071
+DIST boto-2.38.0.tar.gz 1423863 SHA256 d9083f91e21df850c813b38358dc83df16d7f253180a1344ecfedce24213ecf2 SHA512 577672007348db846d041c0906806c62eb77653b1335645cc852c603f5d32991ca648aacb884676af02043914c91ab6f41666b36b5b1ae23a3a354bdf9f3f75a WHIRLPOOL de704484ed38a0d0322ef289fd0657b6d1141c0f77aa6725e338dd51d78bed39a7ef1ebdec54a659d83dae30c14196f2410507d9aeec070126bbe13565b210ba
diff --git a/dev-python/boto/boto-2.27.0.ebuild b/dev-python/boto/boto-2.27.0.ebuild
new file mode 100644
index 000000000000..817052415cd2
--- /dev/null
+++ b/dev-python/boto/boto-2.27.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Amazon Web Services API"
+HOMEPAGE="https://github.com/boto/boto http://pypi.python.org/pypi/boto"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 arm ppc sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+# requires Amazon Web Services keys to pass some tests
+RESTRICT="test"
+
+python_test() {
+ esetup.py test
+}
diff --git a/dev-python/boto/boto-2.31.1.ebuild b/dev-python/boto/boto-2.31.1.ebuild
new file mode 100644
index 000000000000..22b83cbe8f00
--- /dev/null
+++ b/dev-python/boto/boto-2.31.1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Amazon Web Services API"
+HOMEPAGE="https://github.com/boto/boto http://pypi.python.org/pypi/boto"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+# requires Amazon Web Services keys to pass some tests
+RESTRICT="test"
+
+python_test() {
+ esetup.py test
+}
diff --git a/dev-python/boto/boto-2.34.0.ebuild b/dev-python/boto/boto-2.34.0.ebuild
new file mode 100644
index 000000000000..22b83cbe8f00
--- /dev/null
+++ b/dev-python/boto/boto-2.34.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Amazon Web Services API"
+HOMEPAGE="https://github.com/boto/boto http://pypi.python.org/pypi/boto"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+# requires Amazon Web Services keys to pass some tests
+RESTRICT="test"
+
+python_test() {
+ esetup.py test
+}
diff --git a/dev-python/boto/boto-2.35.1.ebuild b/dev-python/boto/boto-2.35.1.ebuild
new file mode 100644
index 000000000000..7bcd75f73f50
--- /dev/null
+++ b/dev-python/boto/boto-2.35.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Amazon Web Services API"
+HOMEPAGE="https://github.com/boto/boto http://pypi.python.org/pypi/boto"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 arm ppc sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+# requires Amazon Web Services keys to pass some tests
+RESTRICT="test"
+
+python_test() {
+ "${PYTHON}" tests/test.py -v || die "Tests fail with ${EPYTHON}"
+}
diff --git a/dev-python/boto/boto-2.38.0.ebuild b/dev-python/boto/boto-2.38.0.ebuild
new file mode 100644
index 000000000000..3bc86070a3ce
--- /dev/null
+++ b/dev-python/boto/boto-2.38.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Amazon Web Services API"
+HOMEPAGE="https://github.com/boto/boto http://pypi.python.org/pypi/boto"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="doc test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+
+# requires Amazon Web Services keys to pass some tests
+RESTRICT="test"
+
+python_test() {
+ "${PYTHON}" tests/test.py -v || die "Tests fail with ${EPYTHON}"
+}
+
+python_prepare_all() {
+ # Prevent un-needed d'loading
+ sed -e "s/, 'sphinx.ext.intersphinx'//" -i docs/source/conf.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ if use doc; then
+ # Appease the doc build and supply a file for _static
+ # the usual emake -C docs doesn't work under this authorship
+ cd docs && mkdir source/_static || die
+ emake html
+ fi
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/build/html/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/boto/metadata.xml b/dev-python/boto/metadata.xml
new file mode 100644
index 000000000000..2ecc58207366
--- /dev/null
+++ b/dev-python/boto/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <maintainer>
+ <email>vapier@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="google-code">boto</remote-id>
+ <remote-id type="pypi">boto</remote-id>
+ <remote-id type="github">boto/boto</remote-id>
+ </upstream>
+</pkgmetadata>