summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/cbor2/cbor2-5.4.0.ebuild')
-rw-r--r--dev-python/cbor2/cbor2-5.4.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/cbor2/cbor2-5.4.0.ebuild b/dev-python/cbor2/cbor2-5.4.0.ebuild
new file mode 100644
index 000000000000..aa8f211a2716
--- /dev/null
+++ b/dev-python/cbor2/cbor2-5.4.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Pure Python CBOR (de)serializer with extensive tag support"
+HOMEPAGE="https://github.com/agronholm/cbor2 https://pypi.org/project/cbor2/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # remove pytest-cov dep
+ sed -e "s/pytest-cov//" \
+ -e "s/--cov //" \
+ -i setup.cfg || die
+
+ distutils-r1_python_prepare_all
+}