summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/cliapp')
-rw-r--r--dev-python/cliapp/Manifest3
-rw-r--r--dev-python/cliapp/cliapp-1.20130808.ebuild31
-rw-r--r--dev-python/cliapp/cliapp-1.20140315.ebuild31
-rw-r--r--dev-python/cliapp/cliapp-1.20150305.ebuild30
-rw-r--r--dev-python/cliapp/metadata.xml8
5 files changed, 103 insertions, 0 deletions
diff --git a/dev-python/cliapp/Manifest b/dev-python/cliapp/Manifest
new file mode 100644
index 000000000000..306e9d833962
--- /dev/null
+++ b/dev-python/cliapp/Manifest
@@ -0,0 +1,3 @@
+DIST cliapp-1.20150305.tar.gz 55133 SHA256 09865ea3b2e63b41f4399997651d2c19c918922745b570530ff7dd5f77e49bd9 SHA512 a32e987bfc6e401672dc1e94fb29034b96fec5bba5864e1001d52460ecdd6cb903ad1bbbe52cfb6d8d880abd029c98f26c3edca8ed79ec10f77e86bfff595aa3 WHIRLPOOL 2286e990958f5012146ac07635f9ce4f1adf96b34cc4d47d4e2d21f472d576cd71a3633591f1e855eb79e3155c1d942cacabc1e96e1413d851f2b78f1d8a3578
+DIST python-cliapp_1.20130808.orig.tar.gz 50236 SHA256 62944c5b99beecb3fe5fff5321b35b71e0cc21c9cc212ebbad26b00cd5c42e45 SHA512 6f8b3bdcf2e737ecf3ebc92f43b85aaf9fbf848635ddcdf7f252dca9a2ea7b8fceb47908742cbbb2e25695ce7ffc7110053c9d648f3616aff87434ecdcb0b493 WHIRLPOOL 5d4f253ae265b37ae59679625daafd7bde39cdb8403663c3b537d27108f47e908888efc504e9e63d20ac0f7e564148ec0424a39864f76b1047116ed9b8f5a93e
+DIST python-cliapp_1.20140315.orig.tar.gz 51107 SHA256 55bec495881ba6759c07f1b94658e3b3b21fa3f04c8bbac2c5fe8b8ce1bf862d SHA512 ce538baec212d5d5149b0aa0ab542919e465fee6700104079842022bc47ef42e65d42179689e998d524feb6b7981e3e396f30266a4a8aa7373ebf1ae8013c2d9 WHIRLPOOL 3237ee51e1c8c15355e1b8a24e25f5c70eb242783e7be226bc400e750e98f708ccf3eb004a2bae4a6b8dc7ba4d39f512de8db4577123a5433e3ffc4f50bf7c71
diff --git a/dev-python/cliapp/cliapp-1.20130808.ebuild b/dev-python/cliapp/cliapp-1.20130808.ebuild
new file mode 100644
index 000000000000..970a723653e9
--- /dev/null
+++ b/dev-python/cliapp/cliapp-1.20130808.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Framework for Unix-like command line programs"
+HOMEPAGE="http://liw.fi/cliapp/"
+SRC_URI="http://code.liw.fi/debian/pool/main/p/python-${PN}/python-${PN}_${PV}.orig.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test"
+
+DEPEND="${PYTHON_DEPS}
+ test? ( dev-python/CoverageTestRunner )"
+
+src_test() {
+ addwrite /proc/self/comm
+ local DISTUTILS_NO_PARALLEL_BUILD=1
+ distutils-r1_src_test
+}
+
+python_test() {
+ emake check
+}
diff --git a/dev-python/cliapp/cliapp-1.20140315.ebuild b/dev-python/cliapp/cliapp-1.20140315.ebuild
new file mode 100644
index 000000000000..a84715532410
--- /dev/null
+++ b/dev-python/cliapp/cliapp-1.20140315.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Framework for Unix-like command line programs"
+HOMEPAGE="http://liw.fi/cliapp/"
+SRC_URI="http://code.liw.fi/debian/pool/main/p/python-${PN}/python-${PN}_${PV}.orig.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test"
+
+DEPEND="${PYTHON_DEPS}
+ test? ( dev-python/CoverageTestRunner )"
+
+src_test() {
+ use test && addwrite /proc/self/comm
+ local DISTUTILS_NO_PARALLEL_BUILD=1
+ distutils-r1_src_test
+}
+
+python_test() {
+ emake check
+}
diff --git a/dev-python/cliapp/cliapp-1.20150305.ebuild b/dev-python/cliapp/cliapp-1.20150305.ebuild
new file mode 100644
index 000000000000..ae2b32da68e2
--- /dev/null
+++ b/dev-python/cliapp/cliapp-1.20150305.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Framework for Unix-like command line programs"
+HOMEPAGE="http://liw.fi/cliapp/"
+SRC_URI="http://git.liw.fi/cgi-bin/cgit/cgit.cgi/cliapp/snapshot/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test"
+
+DEPEND="${PYTHON_DEPS}
+ test? ( dev-python/CoverageTestRunner )"
+
+src_test() {
+ use test && addwrite /proc/self/comm
+ distutils-r1_src_test
+}
+
+python_test() {
+ emake check
+}
diff --git a/dev-python/cliapp/metadata.xml b/dev-python/cliapp/metadata.xml
new file mode 100644
index 000000000000..ea7bd021a21e
--- /dev/null
+++ b/dev-python/cliapp/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>mschiff@gentoo.org</email>
+ <name>Marc Schiffbauer</name>
+ </maintainer>
+</pkgmetadata>