summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/colorspacious')
-rw-r--r--dev-python/colorspacious/colorspacious-1.1.2.ebuild9
1 files changed, 3 insertions, 6 deletions
diff --git a/dev-python/colorspacious/colorspacious-1.1.2.ebuild b/dev-python/colorspacious/colorspacious-1.1.2.ebuild
index ee8f6811f475..7b95376ce7aa 100644
--- a/dev-python/colorspacious/colorspacious-1.1.2.ebuild
+++ b/dev-python/colorspacious/colorspacious-1.1.2.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{6,7,8} )
+PYTHON_COMPAT=( python3_{6..9} )
inherit distutils-r1
DESCRIPTION="Powerful, accurate, and easy-to-use Python library for colorspace conversions"
@@ -12,14 +12,11 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="amd64 ~arm ~arm64 ~ppc ppc64 ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
RDEPEND="
dev-python/numpy[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- app-arch/unzip
- test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests nose
python_test() {
nosetests -v --all-modules || die "Tests fail with ${EPYTHON}"