summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/csv23/csv23-0.3.2-r1.ebuild')
-rw-r--r--dev-python/csv23/csv23-0.3.2-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/csv23/csv23-0.3.2-r1.ebuild b/dev-python/csv23/csv23-0.3.2-r1.ebuild
new file mode 100644
index 000000000000..a2facab53e10
--- /dev/null
+++ b/dev-python/csv23/csv23-0.3.2-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8,9} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="Python 2/3 unicode CSV compatibility layer"
+HOMEPAGE="
+ https://pypi.org/project/csv23/
+ https://github.com/xflr6/csv23/"
+SRC_URI="https://github.com/xflr6/csv23/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ppc ppc64 ~riscv sparc x86"
+
+BDEPEND="
+ test? (
+ >=dev-python/pytest-4.6[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -i -e '/--cov/d' setup.cfg || die
+ distutils-r1_src_prepare
+}