summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/doit-py')
-rw-r--r--dev-python/doit-py/Manifest3
-rw-r--r--dev-python/doit-py/doit-py-0.4.0-r2.ebuild27
-rw-r--r--dev-python/doit-py/doit-py-0.5.0-r1.ebuild37
-rw-r--r--dev-python/doit-py/doit-py-0.5.0.ebuild26
-rw-r--r--dev-python/doit-py/metadata.xml7
5 files changed, 42 insertions, 58 deletions
diff --git a/dev-python/doit-py/Manifest b/dev-python/doit-py/Manifest
index afd09d5bed7c..7b7691a48937 100644
--- a/dev-python/doit-py/Manifest
+++ b/dev-python/doit-py/Manifest
@@ -1,2 +1 @@
-DIST doit-py-0.4.0.tar.gz 16534 BLAKE2B 390a7ac17efc1938176ff6aad8fd404b8a0155e82dd2f346cd416d0357cc888e1b3e84dd9ddb19260bc9ee463e013ae544032199967a6ace7d63840a178e0933 SHA512 72aa850928c99bf43eefd827334b361243da3b26283fa358ed3f7fba72d1916b1cbe50e581d3d62ed3b4f0efb9b5d1e7f59c3dc913b2ee27e6503bf4e47def33
-DIST doit-py-0.5.0.tar.gz 15174 BLAKE2B 092f21549d3c088baf8a96b8dd7575304d08c7ae7b0472e7a890159247422060af06c1cc14064cd608bd59e71788067c5374953b16f4511971bb3018c0245cd4 SHA512 f9e70be30f47b7251bdb479762dabe655be898f9fe37fc5ac6608110a82863a08002271620569745f9ec2f47c03529c044a6ea74244b8bb6438b3fbe7e4c28f7
+DIST doit-py-0.5.0.gh.tar.gz 15174 BLAKE2B 092f21549d3c088baf8a96b8dd7575304d08c7ae7b0472e7a890159247422060af06c1cc14064cd608bd59e71788067c5374953b16f4511971bb3018c0245cd4 SHA512 f9e70be30f47b7251bdb479762dabe655be898f9fe37fc5ac6608110a82863a08002271620569745f9ec2f47c03529c044a6ea74244b8bb6438b3fbe7e4c28f7
diff --git a/dev-python/doit-py/doit-py-0.4.0-r2.ebuild b/dev-python/doit-py/doit-py-0.4.0-r2.ebuild
deleted file mode 100644
index 796e18ef3f01..000000000000
--- a/dev-python/doit-py/doit-py-0.4.0-r2.ebuild
+++ /dev/null
@@ -1,27 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python3_{6,7} )
-
-inherit distutils-r1
-
-DESCRIPTION="doit tasks for python stuff"
-HOMEPAGE="https://pythonhosted.org/doit-py/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 ~x86"
-
-DEPEND="
- test? (
- dev-python/pyflakes[${PYTHON_USEDEP}]
- dev-python/coverage[${PYTHON_USEDEP}]
- app-text/hunspell[l10n_en]
- )"
-RDEPEND="
- dev-python/configclass[${PYTHON_USEDEP}]"
-
-distutils_enable_sphinx doc
-distutils_enable_tests pytest
diff --git a/dev-python/doit-py/doit-py-0.5.0-r1.ebuild b/dev-python/doit-py/doit-py-0.5.0-r1.ebuild
new file mode 100644
index 000000000000..1d713f67d6d6
--- /dev/null
+++ b/dev-python/doit-py/doit-py-0.5.0-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="doit tasks for python stuff"
+HOMEPAGE="
+ https://pythonhosted.org/doit-py/
+ https://github.com/pydoit/doit-py/
+ https://pypi.org/project/doit-py/
+"
+SRC_URI="
+ https://github.com/pydoit/doit-py/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 arm64 ~riscv x86"
+
+RDEPEND="
+ dev-python/configclass[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ app-text/hunspell[l10n_en]
+ dev-python/pyflakes[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx doc
+distutils_enable_tests pytest
diff --git a/dev-python/doit-py/doit-py-0.5.0.ebuild b/dev-python/doit-py/doit-py-0.5.0.ebuild
deleted file mode 100644
index fde1bd900733..000000000000
--- a/dev-python/doit-py/doit-py-0.5.0.ebuild
+++ /dev/null
@@ -1,26 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python3_{6,7,8} )
-
-inherit distutils-r1
-
-DESCRIPTION="doit tasks for python stuff"
-HOMEPAGE="https://pythonhosted.org/doit-py/ https://github.com/pydoit/doit-py"
-SRC_URI="https://github.com/pydoit/doit-py/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-DEPEND="
- test? (
- app-text/hunspell[l10n_en]
- dev-python/pyflakes[${PYTHON_USEDEP}]
- )"
-RDEPEND="
- dev-python/configclass[${PYTHON_USEDEP}]"
-
-distutils_enable_sphinx doc
-distutils_enable_tests pytest
diff --git a/dev-python/doit-py/metadata.xml b/dev-python/doit-py/metadata.xml
index 80c77d8b86a0..a494487b2ce4 100644
--- a/dev-python/doit-py/metadata.xml
+++ b/dev-python/doit-py/metadata.xml
@@ -1,14 +1,15 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer type="person">
+ <maintainer type="person" proxied="yes">
<email>azamat.hackimov@gmail.com</email>
<name>Azamat H. Hackimov</name>
</maintainer>
- <maintainer type="project">
+ <maintainer type="project" proxied="proxy">
<email>proxy-maint@gentoo.org</email>
<name>Proxy Maintainers</name>
</maintainer>
+ <stabilize-allarches/>
<upstream>
<remote-id type="github">pydoit/doit-py</remote-id>
<remote-id type="pypi">doit-py</remote-id>