summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/encore/encore-0.4.0.ebuild')
-rw-r--r--dev-python/encore/encore-0.4.0.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/encore/encore-0.4.0.ebuild b/dev-python/encore/encore-0.4.0.ebuild
new file mode 100644
index 000000000000..906ff33c11ac
--- /dev/null
+++ b/dev-python/encore/encore-0.4.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Enthought Tool Suite: collection of core-level utility modules"
+HOMEPAGE="https://github.com/enthought/encore"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
+IUSE="doc examples test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ virtual/python-futures[${PYTHON_USEDEP}]
+ )"
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ if [[ ${EPYTHON} == python2.6 ]]; then
+ ewarn "Tests disabled for ${EPYTHON}"
+ return 0
+ fi
+ nosetests || die
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ use doc && dohtml -r docs/build/html/*
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}