summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/flake8/flake8-4.0.1.ebuild')
-rw-r--r--dev-python/flake8/flake8-4.0.1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/flake8/flake8-4.0.1.ebuild b/dev-python/flake8/flake8-4.0.1.ebuild
new file mode 100644
index 000000000000..8bf1116ff1cf
--- /dev/null
+++ b/dev-python/flake8/flake8-4.0.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( pypy3 python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="A wrapper around PyFlakes, pep8 & mccabe"
+HOMEPAGE="https://gitlab.com/pycqa/flake8 https://pypi.org/project/flake8/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+# requires.txt inc. mccabe however that creates a circular dep
+RDEPEND="
+ >=dev-python/pyflakes-2.4.0[${PYTHON_USEDEP}]
+ <dev-python/pyflakes-2.5.0[${PYTHON_USEDEP}]
+ >=dev-python/pycodestyle-2.8.0[${PYTHON_USEDEP}]
+ <dev-python/pycodestyle-2.9.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/importlib_metadata[${PYTHON_USEDEP}]' pypy3)
+"
+PDEPEND="
+ >=dev-python/mccabe-0.6.0[${PYTHON_USEDEP}]
+ <dev-python/mccabe-0.7.0[${PYTHON_USEDEP}]
+"
+BDEPEND="${RDEPEND}
+ test? (
+ ${PDEPEND}
+ )
+"
+
+distutils_enable_sphinx docs/source dev-python/sphinx-prompt dev-python/sphinx_rtd_theme
+distutils_enable_tests --install pytest
+
+src_prepare() {
+ # remove version-limited dep
+ sed -i -e '/importlib-metadata/d' setup.cfg || die
+ distutils-r1_src_prepare
+}