summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/flit/flit-3.3.0.ebuild')
-rw-r--r--dev-python/flit/flit-3.3.0.ebuild41
1 files changed, 0 insertions, 41 deletions
diff --git a/dev-python/flit/flit-3.3.0.ebuild b/dev-python/flit/flit-3.3.0.ebuild
deleted file mode 100644
index b7434f5ec52d..000000000000
--- a/dev-python/flit/flit-3.3.0.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 2019-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_SETUPTOOLS=pyproject.toml
-PYTHON_COMPAT=( python3_{8..10} pypy3 )
-inherit distutils-r1
-
-DESCRIPTION="Simplified packaging of Python modules"
-HOMEPAGE="https://github.com/takluyver/flit https://flit.readthedocs.io/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-RDEPEND="
- >=dev-python/flit_core-3.3.0[${PYTHON_USEDEP}]
- dev-python/intreehooks[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- dev-python/requests_download[${PYTHON_USEDEP}]
- dev-python/toml[${PYTHON_USEDEP}]
-"
-BDEPEND="
- sys-apps/grep
- sys-apps/findutils
- test? (
- dev-python/responses[${PYTHON_USEDEP}]
- dev-python/testpath[${PYTHON_USEDEP}]
- )
-"
-
-PATCHES=(
- "${FILESDIR}/flit-3.2.0-tests.patch"
-)
-
-distutils_enable_tests pytest
-distutils_enable_sphinx doc \
- dev-python/sphinxcontrib-github-alt \
- dev-python/pygments-github-lexers \