summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/foolscap/foolscap-0.6.4-r1.ebuild')
-rw-r--r--dev-python/foolscap/foolscap-0.6.4-r1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/foolscap/foolscap-0.6.4-r1.ebuild b/dev-python/foolscap/foolscap-0.6.4-r1.ebuild
new file mode 100644
index 000000000000..acb53bf367ae
--- /dev/null
+++ b/dev-python/foolscap/foolscap-0.6.4-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="RPC protocol for Twisted"
+HOMEPAGE="http://foolscap.lothar.com/trac http://pypi.python.org/pypi/foolscap"
+SRC_URI="http://${PN}.lothar.com/releases/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="doc ssl"
+
+RDEPEND=">=dev-python/twisted-core-2.4.0[${PYTHON_USEDEP}]
+ dev-python/twisted-web[${PYTHON_USEDEP}]
+ ssl? ( dev-python/pyopenssl[${PYTHON_USEDEP}] )"
+DEPEND="${DEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ local -x LC_ALL=C
+ trial ${PN} || die "Tests fail for ${EPYTHON}"
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ if use doc; then
+ dodoc doc/*.txt
+ dohtml -A py,tpl,xhtml -r doc/*
+ fi
+}