summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/genshi/genshi-0.7.3-r1.ebuild')
-rw-r--r--dev-python/genshi/genshi-0.7.3-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/genshi/genshi-0.7.3-r1.ebuild b/dev-python/genshi/genshi-0.7.3-r1.ebuild
new file mode 100644
index 000000000000..7c06bf78d983
--- /dev/null
+++ b/dev-python/genshi/genshi-0.7.3-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_{6,7,8}} pypy3 )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+inherit distutils-r1
+
+DESCRIPTION="Python toolkit for stream-based generation of output for the web"
+HOMEPAGE="http://genshi.edgewall.org/ https://pypi.org/project/Genshi/"
+SRC_URI="mirror://pypi/G/${PN^}/${P^}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
+IUSE="doc examples"
+
+S="${WORKDIR}/${P^}"
+
+distutils_enable_tests setup.py
+
+python_install_all() {
+ if use doc; then
+ dodoc doc/*.txt
+ fi
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+ distutils-r1_python_install_all
+}