summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/git-review/git-review-1.26.0.ebuild')
-rw-r--r--dev-python/git-review/git-review-1.26.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/git-review/git-review-1.26.0.ebuild b/dev-python/git-review/git-review-1.26.0.ebuild
new file mode 100644
index 000000000000..10d16800a468
--- /dev/null
+++ b/dev-python/git-review/git-review-1.26.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Tool to submit code to Gerrit"
+HOMEPAGE="https://git.openstack.org/cgit/openstack-infra/git-review"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/pbr-0.8.0[${PYTHON_USEDEP}]
+"
+RDEPEND="
+ >=dev-python/requests-1.1[${PYTHON_USEDEP}]
+"
+
+python_prepare_all() {
+ sed -i '/^argparse/d' requirements.txt || die
+ distutils-r1_python_prepare_all
+}